PDA

View Full Version : question about Ubuntu.



Mystic Muse
2009-07-11, 03:23 AM
how does one get headphones to work on it? mine won't.

Ichneumon
2009-07-11, 03:55 AM
Which version of ubuntu are you using?

Mystic Muse
2009-07-11, 03:56 AM
8.10 I believe.

kamikasei
2009-07-11, 05:34 AM
Do you have speakers? Do the speakers work?

Headphones aren't something you have to get to work with your machine like, say, a printer. You just need to make sure the headphone output is having sound sent to it. Check the sound settings.

Mystic Muse
2009-07-11, 05:40 AM
Do you have speakers? Do the speakers work?

Headphones aren't something you have to get to work with your machine like, say, a printer. You just need to make sure the headphone output is having sound sent to it. Check the sound settings.

the speakers work fine. it's on a laptop if that affects anything.

the problem is my computer won't send any sound to the headphones even though it should and just sends it to the speakers.

kamikasei
2009-07-11, 06:03 AM
Well, the number one piece of advice I can give you for solving any problem on Ubuntu is to read the documentation. Google up the official forums and wiki, etc.

My best guess would be to take a look at System->Sound and make sure that the mixer has the headphone output selected. It might just have a handful of options chosen, so select them all. (I'm assuming your setup is new and that you didn't have everything working fine earlier until it suddenly and inexplicably stopped.)

Helanna
2009-07-11, 07:55 AM
This may not be Ubuntu's problem. I occasionally have the same problem, and I'm running Vista. What always worked for me was just closing the laptop and reopening it, but I only ever had the problem randomly while it sounds like it never works for you.

Like other people said, check your settings and also make sure you've got the headphones plugged into the headphone jack (I'm sure that you do, but the sheer amount of times my sisters/mom ask me to look at their computer for stupid stuff like that makes me wary :smalltongue:)

Avilan the Grey
2009-07-11, 11:55 AM
Are they USB headphones or the old kind?

With USB Headphones:
I find that in both Vista and Linux (Ubuntu and Mint, which are the only two I am using, and one is based on the other) the key is to make the Headphones the default speakers. Otherwise the computer will ignore the headphones, since the default speakers (the normal speakers) are still working.
If you make the headphones default, the computer will switch to them automatically when you plug them in. Of course, to make them default in the first place, you have to have them plugged in when you do the initial setting.

With old kind:
You have to manually tell the computer to use the headphones instead of the normal speakers.


Also, some media players have separate settings that ignores Ubuntus settings (I guess the idea is that you can watch a movie in surround sound and normal computer sounds are in stereo only).

VeisuItaTyhjyys
2009-07-11, 11:58 AM
What brand of laptop do you have?

There's a fairly common problem on laptos where Ubuntu ignores the headphone jack. It keeps playing through the speakers even when headphones are plugged in. If that's the problem, edit "/etc/modprobe.d/alsa-base" by adding a line of code pertaining to your laptop, for instance "options snd-hda-intel model=vaio" on a Sony Vaio, which seems to be the most common source of this problem (although, I, personally, had it on a Fujitsu). Anyway, when you've added that line, save the file and reboot your machine.