View Full Version : I'm not entirely sure where I ought ask this (It's a PC troubleshooting question)

2010-01-22, 04:19 PM
I hope this okay here, if not, I'm sorry, let us move the thread post haste.

I've got a Sony Vaio VGC-RC110G that I'm working on, and I'm having an absolute bear of a time trying to get the drivers for it. The on-board ethernet has no driver, but I can install a USB ethernet card to get the computer onto the internet. The problems I have encountered thus far:

- Sony's PC support site refuses to identify the computer, even though I know for a fact that I have my model number correct, and that the hardware is what is standard for that model.

- When I manually input the model number, Sony's site gives me a list of drivers for that model number, as well as a few software updates. Every single one of the downloads for the model number download just fine, but when I try to run the executable for them, after a brief attempt to confirm the PC's model, the driver gives an error stating that the driver is not intended for this model, and immediately closes.

- Windows has likewise been unable to find the drivers on its own (I didn't expect it to, but I tried anyway), no matter if I direct it to a folder where the drivers have been downloaded, or if I have it connect to the internet.

- Sony's online support technicians are rubbish. After wasting a great deal of my time, their "answer" to my question (which, oddly enough, was totally unrelated to the question I asked) was to draw a red circle around the series of missing drivers in the device manager, which caused me to lose my temper, and possibly shake the abyss where the operator's soul used to be at its very foundations.

So, my plea to the Playground: is there anyone out there who has successfully re-installed Windows on a Vaio without any kind of disc from Sony, and if you were able to get the drivers to work, how did you do it? :smallfrown:

2010-01-22, 04:33 PM
A lot of driver installers are really just zip files with a fancy extension. Maybe you could find a way to unpack them and then point windows to the extracted files. That would bypass the model checker.

If you're willing to risk tech support again, don't tell them about your USB ethernet. Just say you lost the driver disk and request a new one.

If all else fails, there's always linux. I bet Ubuntu comes preinstalled with all your drivers (except maybe video).

2010-01-22, 05:51 PM
If I could put Linux on here, I would. I'm that fed up with Sony. However, *after re-reading the post* I also don't know how to unpack a .exe file. I'll look into that and post the result.

EDIT: I managed to circumvent the language error on the discs I had available, and am now able to skip the initial model check (there's an application that's bombing out before I can install)... doing so appears to make it so that I can install drivers now. If we could keep the thread until tomorrow afternoon, though, that would be appreciated, just in case something happens and I still need help. :smallredface:

2010-01-22, 06:13 PM
If I could put Linux on here, I would. I'm that fed up with Sony. However, *after re-reading the post* I also don't know how to unpack a .exe file. I'll look into that and post the result.

If the driver package that you downloaded is a .exe file, then the only way to unpack it is to run the file. It shouldn't matter what machine you're trying to run it on, the exe-file should run and unpack the driver.

I went in to check on the Sony webpage, and found two different Ethernet drivers for your model:

The Intel PRO/1000 Network Connection Manager - Filename: INDETH-00705706-US.EXE (http://esupport.sony.com/US/perl/swu-download.pl?mdl=VGCRC110G&upd_id=1970&os_id=16)

And the Intel Gigabit Ethernet Driver Update - Filename : INDETH-01531801-US.EXE (http://esupport.sony.com/US/perl/swu-download.pl?mdl=VGCRC110G&upd_id=2799&os_id=16)

My guess is that you need to install the Network Connection Manager first, and then the Driver Update after that.

If these are the files you've already tried, and they're giving you the message that they're not intended for your machine, then that is something you need to contact the Sony support about again. And if they give you incompetent information, demand to speak to a manager.
Unfortunately, if you do that, you're likely to just be transfered to the next guy over, pretending to be a manager, just to get you thinking that you're higher up in the support chain than you really are.
But you should give it a go anyways.

Edit: I just realized that the drivers I pointed to is only for XP Media Center Edition, though. So if you're not running MCE, they wouldn't work.

2010-01-23, 10:42 AM
Well, circumventing whatever program was failing to run to allow Sony drivers seems to have done the trick. I've got the motherboard working properly with the OS, and the video card *seems* to have stopped having fits (knock on wood). I think I've managed to get it; thanks for the help guys!