Quote Originally Posted by Phasm
Yeah, I know it's 3.0. *I love my A&EG anyway... mmm, all the fabulous toys...
Eh, most of it's compatible with minimal to no conversion anyway. :)